What’s Vulnerable › Vulnerabilities
CVE-2026-55468: Wagtail: Improper restriction handling on Pages admin API
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-24 · updated 2026-10-12
- Weakness: CWE-280
Description
Wagtail is an open source content management system built on Django. Prior to versions 7.0.9, 7.3.4, 7.4.3, and 8.0rc2 on their respective release lines, the internal Pages admin API returns page fields declared in api_fields without sufficient access control, allowing a user with Wagtail admin access to retrieve restricted draft and live page content. This issue is fixed in versions 7.0.9, 7.3.4, 7.4.3, and 8.0rc2.
Affected products
- wagtail: before 7.0.9; from 7.1, < 7.3.4; from 7.4, < 7.4.3; from 8.0rc1, < 8.0rc2
References
- https://github.com/wagtail/wagtail/commit/5608cfb714a130412f862beab53c78de02b79975
- https://github.com/wagtail/wagtail/commit/aef935530d5289406ca325b42747af15f3b28ac4
- https://github.com/wagtail/wagtail/commit/d99d2bec2b0aca46d88014416432c717240cd559
- https://github.com/wagtail/wagtail/commit/e2fa629b7a51ec29d59e45eead930feee0d3c4b3
- https://github.com/wagtail/wagtail/security/advisories/GHSA-3vrh-m9w7-v94f
Get alerted when CVE-2026-55468 or the next vulnerability affects your stack