What’s Vulnerable › Vulnerabilities
CVE-2026-55490: OpenWrt: EAD Integer Underflow → Pre-Auth Denial of Service
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-07-07 · updated 2026-07-10
- Weakness: CWE-191
Description
OpenWrt is a Linux operating system targeting embedded devices. Before v25.12.5, an integer underflow in handle_send_a() of the Emergency Access Daemon allows any unauthenticated attacker on the local network to crash the daemon by sending a single crafted UDP packet. The message length underflows before a bounds check and is then passed to memcpy as a very large size. This issue is fixed v25.12.5.
Affected products
- openwrt: before 25.12.5 — fixed in 25.12.5
How to fix
Upgrade to a fixed version: openwrt 25.12.5. Check the vendor advisory for mitigations.
References
- https://github.com/openwrt/openwrt/commit/63c0767f3d02f7b10b0f0b5293366bd059a08ca5
- https://github.com/openwrt/openwrt/releases/tag/v25.12.5
- https://github.com/openwrt/openwrt/security/advisories/GHSA-9558-77jp-g3fw
Get alerted when CVE-2026-55490 or the next vulnerability affects your stack