What’s Vulnerable › Vulnerabilities
CVE-2026-55514: vLLM denial of service via prompt embeds on M-RoPE models
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-06 · updated 2026-10-25
- Weakness: CWE-617
Description
vLLM is a library for LLM inference and serving. From 0.12.0 to before 0.24.0, sending a pure prompt embeds payload in a /v1/completions request with a model using M-RoPE causes EngineCore to fail an assertion and fatally crash, shutting down the entire server application. Any remote user who is authorized to make a /v1/completions request can make such a request and induce a crash. This issue is fixed in version 0.24.0.
Affected products
- vllm-project vllm: from 0.12.0 before 0.24.0 — fixed in 0.24.0
How to fix
Upgrade to a fixed version: vllm-project vllm 0.24.0. Check the vendor advisory for mitigations.
References
- https://github.com/vllm-project/vllm/commit/470229c37efaf69c86e8bc97482b0b1ff7551c65
- https://github.com/vllm-project/vllm/pull/45252
- https://github.com/vllm-project/vllm/releases/tag/v0.24.0
- https://github.com/vllm-project/vllm/security/advisories/GHSA-33cg-gxv8-3p8g
Get alerted when CVE-2026-55514 or the next vulnerability affects your stack