What’s Vulnerable › Vulnerabilities
CVE-2026-55547: Yamcs: Missing Authorization on Role and Privilege Enumeration Endpoints Allows Any Authenticated User to Disclose Full Security Configuration
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-28 · updated 2026-09-08
- Weakness: CWE-285
Description
Yamcs is a mission control framework. Prior to 5.12.8 and 5.13.2, Yamcs omits SystemPrivilege.ControlAccess checks from IamApi.listRoles, IamApi.getRole, and IamApi.listPrivileges in yamcs-core/src/main/java/org/yamcs/http/api/IamApi.java. Any authenticated account can call GET /api/roles, GET /api/roles/{name}, and GET /api/privileges to enumerate available system privileges and configured role mappings. The disclosure reveals security configuration that can support targeted privilege-escalation attempts. This issue is fixed in versions 5.12.8 and 5.13.2.
Affected products
- yamcs: before 5.12.8; from 5.13.0, < 5.13.2
References
- https://github.com/yamcs/yamcs/commit/c2aec1c242e656e48b52c7f87deea88183bb592d
- https://github.com/yamcs/yamcs/commit/dcaec5f0b2f4231b8e313e94d79a937169c9e0ba
- https://github.com/yamcs/yamcs/releases/tag/yamcs-5.12.8
- https://github.com/yamcs/yamcs/releases/tag/yamcs-5.13.2
- https://github.com/yamcs/yamcs/security/advisories/GHSA-cvw4-55pp-3hfq
- https://github.com/yamcs/yamcs/security/advisories/GHSA-cvw4-55pp-3hfq
Get alerted when CVE-2026-55547 or the next vulnerability affects your stack