What’s Vulnerable › Vulnerabilities
CVE-2026-55555: Dompdf: File existence oracle via font-face stylesheet declaration
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-07-28 · updated 2026-08-05
- Weakness: CWE-203
Description
Dompdf is an HTML to PDF converter for PHP. Versions 3.15 and prior are vulnerable to a File Existence Oracle attack through the manipulation of the CSS @font-face directive. By providing malicious HTML that references local files via the file:// protocol repeatedly, an attacker can trigger PHP memory exhaustion. Because Dompdf behaves differently depending on whether a referenced local file exists (an existing file is processed repeatedly until it triggers an "Allowed memory size exhausted" crash, whereas a missing file fails fast or is ignored and never hits the memory limit), an attacker can use this observable discrepancy as an oracle to enumerate sensitive files on the server regardless of CHROOT restrictions. Exploitation requires the attacker to supply unrestricted or unsanitized HTML in a request that permits large data, plus a configuration where Dompdf's memory limit is low enough to be exhausted (with $_dompdf_show_warnings=true making the overflow easier to reach). This issue has been fixed in version 3.16.
Affected products
- dompdf: before 3.16 — fixed in 3.16
- Packagist Dompdf/Dompdf: before 3.1.6; v0.6.0, v0.6.1, v0.6.2, v0.7.0, v0.7.0-beta, v0.7.0-beta2 (+33) — fixed in 3.1.6
How to fix
Upgrade to a fixed version: dompdf 3.16; Packagist Dompdf/Dompdf 3.1.6. Check the vendor advisory for mitigations.
References
- https://github.com/dompdf/dompdf/commit/75c39a083bf7298044fb27399b4cc183054438b4
- https://github.com/dompdf/dompdf/releases/tag/v3.1.6
- https://github.com/dompdf/dompdf/security/advisories/GHSA-7x2p-4jvh-6384
- https://github.com/dompdf/dompdf/security/advisories/GHSA-7x2p-4jvh-6384
Get alerted when CVE-2026-55555 or the next vulnerability affects your stack