What’s Vulnerable › Vulnerabilities
CVE-2026-55568: Guzzle: Silent HTTPS-Proxy Downgrade to Cleartext
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-23 · updated 2026-06-26
- Weakness: CWE-311
Description
Guzzle is an extensible PHP HTTP client. Prior to 7.12.1, in certain configurations, traffic expected to be protected by TLS on the hop to the proxy is transmitted in cleartext. Proxy authentication credentials (the Proxy-Authorization header, proxy userinfo in the proxy URL, or CURLOPT_PROXYUSERPWD) are sent without encryption, and the CONNECT target host and port for tunneled HTTPS requests are exposed. The built-in cURL handlers (GuzzleHttp\Handler\CurlHandler and GuzzleHttp\Handler\CurlMultiHandler, used by default whenever the PHP cURL extension is available) accept an https:// proxy. libcurl older than 7.50.2 silently treats an https:// proxy as a plaintext http:// proxy. The TLS connection to the proxy is never established, and the proxy leg is cleartext with no error or warning. An application is affected when it sends requests through one of the built-in cURL handlers, configures an https:// proxy expecting the proxy connection itself to be encrypted, and runs with libcurl older than 7.50.2. This vulnerability is fixed in 7.12.1.
Affected products
- guzzle: before 7.12.1 — fixed in 7.12.1
- Packagist Guzzlehttp/Guzzle: before 7.12.1; 4.0.0, 4.0.0-rc.1, 4.0.0-rc.2, 4.0.1, 4.0.2, 4.1.0 (+157) — fixed in 7.12.1
How to fix
Upgrade to a fixed version: guzzle 7.12.1; Packagist Guzzlehttp/Guzzle 7.12.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-55568 or the next vulnerability affects your stack