What’s Vulnerable › Vulnerabilities
CVE-2026-55573: e107: Unsafe deserialization in install.php allows unauthenticated RCE via POP chain
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-14 · updated 2026-10-16
- Weakness: CWE-502
Description
e107 is a content management system (CMS). Prior to 2.3.7, install.php decodes the attacker-controlled previous_steps POST parameter and passes it to unserialize() at file scope and again in the e_install constructor without restricting allowed classes. The installer remains accessible after a normal installation, and a crafted object graph using the bundled GuzzleHttp\Psr7\PumpStream class can flow through paths.hash into site_path, where string coercion invokes an attacker-controlled callable. An unauthenticated attacker who can reach install.php can therefore execute arbitrary PHP functions with the web server process's privileges, leading to full server compromise. This issue is fixed in version 2.3.7.
Affected products
- e107inc e107: before 2.3.7
References
- https://github.com/e107inc/e107/commit/5d6d649e8cf01854d6024d07997c2449fdd75f24
- https://github.com/e107inc/e107/commit/6c404295213952aedb9b3689be19dd4c7ba550b0
- https://github.com/e107inc/e107/releases/tag/v2.3.7
- https://github.com/e107inc/e107/security/advisories/GHSA-c8h6-wpj3-4cr8
- https://github.com/e107inc/e107/security/advisories/GHSA-c8h6-wpj3-4cr8
Get alerted when CVE-2026-55573 or the next vulnerability affects your stack