What’s Vulnerable › Vulnerabilities
CVE-2026-55577: ImageMagick: Heap Buffer Overflow in ImageMagick MVG decoder
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-01 · updated 2026-07-02
- Weakness: CWE-754
Description
ImageMagick is free and open-source software used for editing and manipulating digital images. Prior to versions 6.9.13-51 and 7.1.2-26, a heap buffer overflow occurs in the MVG decoder that could result in an out of bounds write when processing a crafted image. This issue has been fixed in versions 6.9.13-51 and 7.1.2-26.
Affected products
- ImageMagick: before 6.9.13-51; from 7.0.0-0 before 7.1.2-26 — fixed in 6.9.13-51, 7.1.2-26
How to fix
Upgrade to a fixed version: ImageMagick 6.9.13-51, 7.1.2-26. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-55577 or the next vulnerability affects your stack