What’s Vulnerable › Vulnerabilities
CVE-2026-55597: ImageMagick: Heap Buffer Over-Write in JP2 encoder when due to incorrect handling of arguments
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-01 · updated 2026-07-02
- Weakness: CWE-682
Description
ImageMagick is free and open-source software used for editing and manipulating digital images. Prior to version 7.1.2-26, an incorrect handling of arguments can cause a heap buffer over-write in the JP2 encoder. This issue has been fixed in version7.1.2-26.
Affected products
- ImageMagick: before 7.1.2-26 — fixed in 7.1.2-26
How to fix
Upgrade to a fixed version: ImageMagick 7.1.2-26. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-55597 or the next vulnerability affects your stack