What’s Vulnerable › Vulnerabilities
CVE-2026-55599: phpseclib: X.509 certificate validation sends attacker-controlled outbound requests (server-side request forgery) via Authority Information Access
- Severity: medium (CVSS 5.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-06-22 · updated 2026-06-26
- Weakness: CWE-918
Description
phpseclib is a PHP secure communications library. From 0.1.1 until 1.0.30, 2.0.55, and 3.0.54, when an application validates an untrusted X.509 certificate with phpseclib, X509::validateSignature() reads a URL out of that certificate's Authority Information Access (AIA) extension and connects to it. Attacker who supplies certificate fully controls host, port, and path of that connection. URL fetching is enabled by default, and no destination is blocked. An unauthenticated attacker can therefore make a validating server open connections to internal hosts and ports it should never reach, for example loopback 127.0.0.1, cloud metadata address 169.254.169.254, and internal-only services. This is a server-side request forgery (SSRF) caused by an insecure default. This vulnerability is fixed in 1.0.30, 2.0.55, and 3.0.54.
Affected products
- phpseclib: from 0.1.1 before 1.0.30; from 2.0.0 before 2.0.55; from 3.0.0 before 3.0.54 — fixed in 1.0.30, 2.0.55, 3.0.54
- Packagist Phpseclib/Phpseclib: from 0.1.1 before 1.0.30; from 2.0.0 before 2.0.55; from 3.0.0 before 3.0.54; 0.3.0, 0.3.1, 0.3.10, 0.3.5, 0.3.6, 0.3.7 (+132) — fixed in 1.0.30, 2.0.55, 3.0.54
How to fix
Upgrade to a fixed version: phpseclib 1.0.30, 2.0.55, 3.0.54; Packagist Phpseclib/Phpseclib 1.0.30, 2.0.55, 3.0.54. Check the vendor advisory for mitigations.
References
- https://github.com/phpseclib/phpseclib/security/advisories/GHSA-m557-wrgg-6rp4
- https://github.com/phpseclib/phpseclib/security/advisories/GHSA-m557-wrgg-6rp4
Get alerted when CVE-2026-55599 or the next vulnerability affects your stack