What’s Vulnerable › Vulnerabilities
CVE-2026-55697: pnpm: Repository-controlled configDependencies can select a pacquet native install engine
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-06-25 · updated 2026-06-30
- Weakness: CWE-78
Description
pnpm is a package manager. Prior to 10.34.2 and 11.5.3, pnpm can install configDependencies declared in pnpm-workspace.yaml before command dispatch. Before the patch, a repository could declare pacquet or @pnpm/pacquet as a config dependency and pnpm treated that repository-controlled dependency as an install-engine opt-in. During install, pnpm resolved a platform-specific @pacquet/<platform>-<arch>/pacquet binary from node_modules/.pnpm-config/<packageName> and spawned it as the developer or CI user. This vulnerability is fixed in 10.34.2 and 11.5.3.
Affected products
- pnpm: before 10.34.2; from 11.0.0 before 11.5.3 — fixed in 10.34.2, 11.5.3
How to fix
Upgrade to a fixed version: pnpm 10.34.2, 11.5.3. Check the vendor advisory for mitigations.
References
- https://github.com/pnpm/pnpm/security/advisories/GHSA-gj8w-mvpf-x27x
- https://github.com/pnpm/pnpm/security/advisories/GHSA-gj8w-mvpf-x27x
Get alerted when CVE-2026-55697 or the next vulnerability affects your stack