What’s Vulnerable › Vulnerabilities
CVE-2026-55799: Apache Ranger: Remote Code Execution Vulnerability in GraalScriptEngineCreator
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-10 · updated 2026-10-24
- Weakness: CWE-94
Description
Remote Code Execution Vulnerability in GraalScriptEngineCreator in Apache Ranger <= 2.8.0 Users are recommended to upgrade to version 2.9.0, which fixes this issue.
Affected products
- Apache Software Foundation Apache Ranger: before 2.9.0 — fixed in 2.9.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Ranger 2.9.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/mqpdrqrvd47x5vhy03xok4ylbo9wbqgj
- http://www.openwall.com/lists/oss-security/2026/08/09/7
Get alerted when CVE-2026-55799 or the next vulnerability affects your stack