What’s Vulnerable › Vulnerabilities
CVE-2026-55843: Snipe-IT: Improper Privilege Management
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-10 · updated 2026-10-25
- Weakness: CWE-269
Description
Snipe-IT is an IT asset/license management system. Prior to 8.6.0, UsersController::update() passes a missing permission request field through NormalizePermissionsPayloadAction and PreserveUnauthorizedPrivilegedPermissionsAction in a way that can overwrite a target user’s permissions with a sparse result, allowing an administrator updating another administrator, or a user with users.edit updating a regular account, to remove the target’s administrative or granular permissions. This issue is fixed in version 8.6.0.
Affected products
- grokability snipe-it: before 8.6.0 — fixed in 8.6.0
How to fix
Upgrade to a fixed version: grokability snipe-it 8.6.0. Check the vendor advisory for mitigations.
References
- https://github.com/grokability/snipe-it/commit/1cff2d67aabd00ee51d864c1d7fb717494c1d6ad
- https://github.com/grokability/snipe-it/releases/tag/v8.6.0
- https://github.com/grokability/snipe-it/security/advisories/GHSA-j5g3-42wp-gqm3
Get alerted when CVE-2026-55843 or the next vulnerability affects your stack