What’s Vulnerable › Vulnerabilities
CVE-2026-55895: Vim: Vimscript Code Injection in netrw NetrwLocalRmFile() via crafted filename
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-25 · updated 2026-06-26
- Weakness: CWE-78
Description
Vim is an open source, command line text editor. Prior to 9.2.0663, a Vimscript code injection vulnerability exists in s:NetrwLocalRmFile() in the netrw plugin (runtime/pack/dist/opt/netrw/autoload/netrw.vim) when deleting a local file from the browser. A filename derived from the buffer's directory listing is interpolated into an Ex command line passed to :execute with only the backslash character escaped, allowing a crafted filename containing a bar (|) to terminate the intended command and execute arbitrary Vimscript, including shell commands via :call system() and :!. This vulnerability is fixed in 9.2.0663.
Affected products
- vim/vim: before 9.2.0663 — fixed in 9.2.0663
How to fix
Upgrade to a fixed version: vim/vim 9.2.0663. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/55bc757a5d436e59d50fe43f7cda94b118f86cb2
- https://github.com/vim/vim/releases/tag/v9.2.0663
- https://github.com/vim/vim/security/advisories/GHSA-vhh8-v6wx-hjjh
Get alerted when CVE-2026-55895 or the next vulnerability affects your stack