What’s Vulnerable › Vulnerabilities
CVE-2026-56016: CGI::Session::ID::md5 versions before 4.49 for Perl generate predictable session ids from low-entropy sources
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-01 · updated 2026-10-25
- Weakness: CWE-338
Description
CGI::Session::ID::md5 versions before 4.49 for Perl generate predictable session ids from low-entropy sources. The generate_id method builds the session id from a MD5 digest of the process id, the epoch time, and the built-in rand() function. All three are predictable, low-entropy sources: the PID is drawn from a small range, the epoch time can be guessed or read from the HTTP Date header, and Perl's rand() is unsuitable for security purposes because it is predictable and reversible. An attacker who predicts a session id can impersonate the corresponding session and bypass authentication.
Affected products
- MARKSTOS CGI::Session::ID::md5: before 4.49 — fixed in 4.49
How to fix
Upgrade to a fixed version: MARKSTOS CGI::Session::ID::md5 4.49. Check the vendor advisory for mitigations.
References
- https://metacpan.org/release/MARKSTOS/CGI-Session-4.49/changes
- https://metacpan.org/release/MARKSTOS/CGI-Session-4.49/source/lib/CGI/Session/ID/md5.pm
- http://www.openwall.com/lists/oss-security/2026/07/01/6
Get alerted when CVE-2026-56016 or the next vulnerability affects your stack