What’s Vulnerable › Vulnerabilities
CVE-2026-56080: Cap-go - Authentication Logic Flaw in Enforce Password Policy
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-19 · updated 2026-10-25
- Weakness: CWE-287
Description
Capgo before 12.128.2 contains a flaw in the Enforce Password Policy feature: after a Super Admin enables the policy and successfully changes their password to a compliant one, the backend does not update the password-compliance state. As a result, the backend continues to treat the account as non-compliant and repeatedly forces password-reset prompts, permanently locking the Super Admin out of organization access (organization lockout / denial of service) despite valid authentication.
Affected products
- Cap-go capgo: before 12.128.2 — fixed in 12.128.2
How to fix
Upgrade to a fixed version: Cap-go capgo 12.128.2. Check the vendor advisory for mitigations.
References
- https://github.com/Cap-go/capgo/security/advisories/GHSA-78rv-3cqj-36xq
- https://www.vulncheck.com/advisories/cap-go-authentication-logic-flaw-in-enforce-password-policy
- https://github.com/Cap-go/capgo/security/advisories/GHSA-78rv-3cqj-36xq
Get alerted when CVE-2026-56080 or the next vulnerability affects your stack