What’s Vulnerable › Vulnerabilities
CVE-2026-56100: SpringBlade 2.7.3 < 5.0.0 Privilege Escalation via Exposed Feign Endpoint
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-28 · updated 2026-09-16
- Weakness: CWE-862
Description
SpringBlade versions from 2.7.3 up to but not including 5.0.0 contain a privilege escalation vulnerability that allows authenticated attackers to create system administrator accounts by sending crafted POST requests to an unprotected internal Feign user-creation endpoint exposed via @RestController without authorization checks. Attackers can exploit the gateway's authentication filter, which only validates JWT parsing without verifying user roles or caller identity, and leverage a hardcoded JWT signing key embedded in publicly available JARs to forge tokens and escalate privileges from a low-privilege user to administrator, enabling cross-tenant data pollution and persistent backdoor access.
Affected products
- SpringBlade: from 2.7.3 before 5.0.0 — fixed in 5.0.0
How to fix
Upgrade to a fixed version: SpringBlade 5.0.0. Check the vendor advisory for mitigations.
References
- https://gist.github.com/sud0why/e73405057dd7414a8c221ef17e0d0059#file-cve-2026-56100-springblade-authbypass-en-md
- https://github.com/chillzhuang/SpringBlade
- https://github.com/chillzhuang/SpringBlade/commit/c69b9547c942c697da2f3ee6a9265b6004abd645
- https://github.com/chillzhuang/SpringBlade/releases#release-v5.0.0
- https://www.vulncheck.com/advisories/springblade-privilege-escalation-via-exposed-feign-endpoint
Get alerted when CVE-2026-56100 or the next vulnerability affects your stack