What’s Vulnerable › Vulnerabilities
CVE-2026-56109: ALSA Library < 1.2.16.1 Double-Free via parse_def() in conf.c
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-22 · updated 2026-10-25
- Weakness: CWE-415
Description
The Advanced Linux Sound Architecture (ALSA) library before 1.2.16.1 contains a double-free vulnerability in parse_def() in src/conf.c that allows attackers to corrupt memory by supplying maliciously crafted ALSA configuration text. When parsing nested compound or array configuration blocks, parse_def() fails to check return values before continuing, causing snd_config_delete() to be called twice on the same already-freed node, resulting in a NULL-pointer write or invalid memory read.
Affected products
- alsa-project alsa-lib: before 1.2.16.1 — fixed in 1.2.16.1
How to fix
Upgrade to a fixed version: alsa-project alsa-lib 1.2.16.1. Check the vendor advisory for mitigations.
References
- https://github.com/alsa-project/alsa-lib/commit/536dd6f8affdf5197c12a63a71c92a70b2833cc0
- https://github.com/alsa-project/alsa-lib/releases/tag/v1.2.16.1
- https://lore.kernel.org/alsa-devel/CAGt8pqBU0p2voB+qHxWGcNJrKHAcBhAyHUUBPLBN-Yj_SiV6MQ@mail.gmail.com/
- https://www.vulncheck.com/advisories/alsa-library-double-free-via-parse-def-in-conf-c
Get alerted when CVE-2026-56109 or the next vulnerability affects your stack