What’s Vulnerable › Vulnerabilities
CVE-2026-56126: pfSense Plus < 26.07 / CE < 2.9.0 Stored XSS via status_monitoring.php
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-03 · updated 2026-09-09
- Weakness: CWE-79
Description
pfSense Plus before 26.07 and CE before 2.9.0 allow authenticated users with the Status: Monitoring privilege to inject arbitrary JavaScript via graph configuration parameters in /status_monitoring.php. Multiple POST parameters including graph-left, graph-right, time-period, resolution, start-date, end-date, start-time, end-time, graph-type, invert, and refresh-interval are concatenated and written to the global pfSense XML configuration without sanitization, then echoed unsanitized into a JavaScript string context on page render. Because the setting is stored in the global configuration, the payload executes in the browser of every user who visits the Status: Monitoring page.
Affected products
- Netgate pfSense CE: before 2.9.0 — fixed in 2.9.0
- Netgate pfSense Plus: before 26.07 — fixed in 26.07
How to fix
Upgrade to a fixed version: Netgate pfSense CE 2.9.0; Netgate pfSense Plus 26.07. Check the vendor advisory for mitigations.
References
- https://docs.netgate.com/downloads/pfSense-SA-26_09.packages.asc
- https://docs.netgate.com/pfsense/en/latest/releases/2-9-0.html
- https://docs.netgate.com/pfsense/en/latest/releases/26-07.html
- https://www.vulncheck.com/advisories/pfsense-plus-ce-stored-xss-via-status-monitoring-php
Get alerted when CVE-2026-56126 or the next vulnerability affects your stack