What’s Vulnerable › Vulnerabilities
CVE-2026-56127: pfSense Plus < 26.07 / CE < 2.9.0 Stored XSS via firewall_rules_edit.php
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-03 · updated 2026-09-09
- Weakness: CWE-79
Description
pfSense Plus before 26.07 and CE before 2.9.0 allow authenticated users with the Firewall: Rules: Edit privilege to inject arbitrary JavaScript via the descr parameter in /firewall_rules_edit.php. The firewall rule description is stored in the pfSense XML configuration with only backslash-escaping applied and no HTML sanitization, then rendered without encoding in the firewall log table in /status_logs_filter.php. The payload executes in the browser of any user with the Status: Logs: Firewall privilege who views the affected log entries.
Affected products
- Netgate pfSense CE: before 2.9.0 — fixed in 2.9.0
- Netgate pfSense Plus: before 26.07 — fixed in 26.07
How to fix
Upgrade to a fixed version: Netgate pfSense CE 2.9.0; Netgate pfSense Plus 26.07. Check the vendor advisory for mitigations.
References
- https://docs.netgate.com/downloads/pfSense-SA-26_10.webgui.asc
- https://docs.netgate.com/pfsense/en/latest/releases/2-9-0.html
- https://docs.netgate.com/pfsense/en/latest/releases/26-07.html
- https://www.vulncheck.com/advisories/pfsense-plus-ce-stored-xss-via-firewall-rules-edit-php
Get alerted when CVE-2026-56127 or the next vulnerability affects your stack