What’s Vulnerable › Vulnerabilities
CVE-2026-56128: pfSense Plus < 26.07 / CE < 2.9.0 Stored XSS via firewall_schedule_edit.php
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-03 · updated 2026-09-09
- Weakness: CWE-79
Description
pfSense Plus before 26.07 and CE before 2.9.0 allow authenticated users with the Firewall: Schedules: Edit privilege to inject arbitrary JavaScript via the descr parameter in /firewall_schedule_edit.php. The schedule description is stored without HTML sanitization and subsequently inserted into an HTML attribute value in /firewall_rules.php with only single-quote escaping applied, permitting double-quote breakout. The payload executes in the browser of any user with the Firewall: Rules privilege who views the rules list with the affected schedule attached.
Affected products
- Netgate pfSense CE: before 2.9.0 — fixed in 2.9.0
- Netgate pfSense Plus: before 26.07 — fixed in 26.07
How to fix
Upgrade to a fixed version: Netgate pfSense CE 2.9.0; Netgate pfSense Plus 26.07. Check the vendor advisory for mitigations.
References
- https://docs.netgate.com/downloads/pfSense-SA-26_11.webgui.asc
- https://docs.netgate.com/pfsense/en/latest/releases/2-9-0.html
- https://docs.netgate.com/pfsense/en/latest/releases/26-07.html
- https://www.vulncheck.com/advisories/pfsense-plus-ce-stored-xss-via-firewall-schedule-edit-php
Get alerted when CVE-2026-56128 or the next vulnerability affects your stack