What’s Vulnerable › Vulnerabilities
CVE-2026-56130: Apache Shiro: Remember-me cookie isn't checked for expiry on the server
- Severity: low (CVSS 2.0 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-25 · updated 2026-10-25
- Weakness: CWE-294
Description
"Remember me" cookie age is not verified on the server. This potentially allows an attacker to intercept a valid cookie and reuse it indefinitely, even after the configured expiration time has passed. This issue affects all Apache Shiro versions from 1.2.4 through 2.x, and 3.0.0-alpha-1, only when RememberMe functionality is enabled. Upgrade to version 3.0.0 or later, which fixes the issue.
Affected products
- Apache Software Foundation Apache Shiro: from 1.2.4 through 2.99.99; from 3.0.0-alpha-0 through 3.0.0-alpha-1
References
- https://lists.apache.org/thread/9k9b3bmlq516ylvf7cdp3dlrtdtmxbmo
- http://www.openwall.com/lists/oss-security/2026/06/24/8
Get alerted when CVE-2026-56130 or the next vulnerability affects your stack