What’s Vulnerable › Vulnerabilities
CVE-2026-56131
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-19 · updated 2026-10-26
- Weakness: CWE-416
Description
libexpat before 2.8.2 lacks handler call depth tracking for calls to XML_ResumeParser from within handlers in cases of a policy violation. Thus, a use-after-free can occur (similar to the CVE-2026-50219 situation).
Affected products
- libexpat project libexpat: before 2.8.2 — fixed in 2.8.2
How to fix
Upgrade to a fixed version: libexpat project libexpat 2.8.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-56131 or the next vulnerability affects your stack