What’s Vulnerable › Vulnerabilities
CVE-2026-56144: Incorrect Authorization in Elasticsearch Leading to Information Disclosure
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-21 · updated 2026-10-24
- Weakness: CWE-863
Description
Incorrect Authorization (CWE-863) in Elasticsearch can allow an authenticated user with limited index privileges to exploit insufficient authorization controls in the ingest simulation feature. By targeting indices they are not authorized to access directly, the user can cause those indices' configured ingest pipelines to execute and return their output, potentially disclosing data processed or enriched by those pipelines. Additionally, the same feature can be used to retrieve index mapping metadata for indices the user are not authorized to access directly.
Affected products
- Elasticsearch: from 8.12.0 before 8.19.18; from 9.0.0 before 9.3.7; from 9.4.0 before 9.4.4 — fixed in 8.19.18, 9.3.7, 9.4.4
How to fix
Upgrade to a fixed version: Elasticsearch 8.19.18, 9.3.7, 9.4.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-56144 or the next vulnerability affects your stack