What’s Vulnerable › Vulnerabilities
CVE-2026-56148: Uncontrolled Recursion in Elasticsearch Leading to Denial of Service
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-01 · updated 2026-10-25
- Weakness: CWE-674
Description
Uncontrolled Recursion (CWE-674) in Elasticsearch can lead to a denial of service via Excessive Allocation (CAPEC-130). An authenticated user can submit a specially crafted query that causes excessive resource consumption while the request is processed, which may render the affected node unavailable.
Affected products
- Elasticsearch: from 8.0.0 before 8.19.17; from 9.0.0 before 9.3.6; from 9.4.0 before 9.4.3 — fixed in 8.19.17, 9.3.6, 9.4.3
How to fix
Upgrade to a fixed version: Elasticsearch 8.19.17, 9.3.6, 9.4.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-56148 or the next vulnerability affects your stack