What’s Vulnerable › Vulnerabilities
CVE-2026-56151: Improper Input Validation in Kibana Leading to Denial of Service
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-01 · updated 2026-10-25
- Weakness: CWE-20
Description
Improper Input Validation (CWE-20) in Kibana can lead to a denial of service via Input Data Manipulation (CAPEC-153). An authenticated user can submit a specially crafted Fleet policy input that is not correctly validated, which can render Fleet agent, server, and policy management functionality unavailable.
Affected products
- Kibana: from 8.0.0 before 8.19.17; from 9.0.0 before 9.3.6; from 9.4.0 before 9.4.3 — fixed in 8.19.17, 9.3.6, 9.4.3
How to fix
Upgrade to a fixed version: Kibana 8.19.17, 9.3.6, 9.4.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-56151 or the next vulnerability affects your stack