What’s Vulnerable › Vulnerabilities

CVE-2026-56153: Apache HTTP Server: mod_charset_lite: Heap overflow in finish_partial_char

Description

Out-of-bounds Write vulnerability in Apache HTTP Server's mod_charset_lite. This issue affects Apache HTTP Server: from 2.4.0 through 2.4.68.

Affected products

How to fix

Upgrade to a fixed version: Apache HTTP Server 2.4.69. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-56153 or the next vulnerability affects your stack