What’s Vulnerable › Vulnerabilities

CVE-2026-56154: Apache HTTP Server: mod_rewrite use-after-free via %{LA-U:HTTP:...}

Description

Use After Free vulnerability in Apache HTTP Server's mod_rewrite when using lookahead (%{LA-U:HTTP:...}) This issue affects Apache HTTP Server: from 2.4.0 through 2.4.68.

Affected products

How to fix

Upgrade to a fixed version: Apache HTTP Server 2.4.69. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-56154 or the next vulnerability affects your stack