What’s Vulnerable › Vulnerabilities
CVE-2026-56170: ASP.NET Core Denial of Service Vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-14 · updated 2026-10-28
- Weakness: CWE-770
Description
Allocation of resources without limits or throttling in ASP.NET Core allows an unauthorized attacker to deny service over a network.
Affected products
- Microsoft .NET: from 8.0.0 before 8.0.29; from 9.0.0 before 9.0.18; from 10.0.0 before 10.0.6 — fixed in 8.0.29, 9.0.18, 10.0.6
- Microsoft .NET 10.0 runtime: from 10.0.0 before 10.0.10 — fixed in 10.0.10
- Microsoft .NET 8.0 runtime: from 8.0.0 before 8.0.29 — fixed in 8.0.29
- Microsoft .NET 9.0 runtime: from 9.0.0 before 9.0.18 — fixed in 9.0.18
How to fix
Upgrade to a fixed version: Microsoft .NET 8.0.29, 9.0.18, 10.0.6; Microsoft .NET 10.0 runtime 10.0.10; Microsoft .NET 8.0 runtime 8.0.29; Microsoft .NET 9.0 runtime 9.0.18. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-56170 or the next vulnerability affects your stack