What’s Vulnerable › Vulnerabilities
CVE-2026-56217: Capgo - Encrypted Bundle Policy Bypass via Direct PostgREST Update
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-08 · updated 2026-10-25
- Weakness: CWE-284
Description
Capgo before 12.128.2 contains a policy bypass vulnerability in app_versions update enforcement that allows app-scoped API keys to downgrade encrypted bundles to non-encrypted state. Attackers with app-scoped all API keys can directly update the app_versions table via PostgREST to clear session_key and key_id fields, bypassing organization-enforced encrypted-bundle policies and weakening OTA security controls.
Affected products
- Capgo: before 12.128.2 — fixed in 12.128.2
How to fix
Upgrade to a fixed version: Capgo 12.128.2. Check the vendor advisory for mitigations.
References
- https://github.com/Cap-go/capgo/security/advisories/GHSA-4qwf-mrgx-mvfx
- https://www.vulncheck.com/advisories/capgo-encrypted-bundle-policy-bypass-via-direct-postgrest-update
- https://github.com/Cap-go/capgo/security/advisories/GHSA-4qwf-mrgx-mvfx
Get alerted when CVE-2026-56217 or the next vulnerability affects your stack