What’s Vulnerable › Vulnerabilities
CVE-2026-56228: Capgo - Denial of Service via Improper Password Policy Length Validation
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-20 · updated 2026-06-23
- Weakness: CWE-20
Description
Capgo before 12.128.2 fails to enforce a maximum value on the minimum password length field in its password policy configuration. An authenticated organization administrator can set an extremely large numeric value (e.g., billions of characters) as the minimum password length, making compliance impossible for all organization members. Once the policy is enabled, users (including administrators) are unable to change their passwords or access the organization, resulting in an organization-wide account lockout and application-level denial of service.
Affected products
- Capgo: before 12.128.2 — fixed in 12.128.2
How to fix
Upgrade to a fixed version: Capgo 12.128.2. Check the vendor advisory for mitigations.
References
- https://github.com/Cap-go/capgo/security/advisories/GHSA-vhjp-62qf-33mx
- https://www.vulncheck.com/advisories/capgo-denial-of-service-via-improper-password-policy-length-validation
Get alerted when CVE-2026-56228 or the next vulnerability affects your stack