What’s Vulnerable › Vulnerabilities
CVE-2026-56259: Crawl4AI - LLM Credential Exfiltration via base_url and Environment Variable Resolution
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-12 · updated 2026-07-14
- Weakness: CWE-200
Description
Crawl4AI before 0.8.8 contains credential exfiltration vulnerabilities in the Docker API server that allow attackers to redirect LLM API calls to attacker-controlled endpoints and read arbitrary environment variables. Attackers can exploit the unauthenticated /md, /llm, and /llm/job endpoints by supplying a malicious base_url parameter and setting api_token to env:VARIABLE_NAME to exfiltrate provider API keys and server secrets including JWT SECRET_KEY for authentication bypass.
Affected products
- unclecode crawl4ai: before 0.8.8 — fixed in 0.8.8
How to fix
Upgrade to a fixed version: unclecode crawl4ai 0.8.8. Check the vendor advisory for mitigations.
References
- https://github.com/unclecode/crawl4ai/security/advisories/GHSA-f989-c77f-r2cq
- https://www.vulncheck.com/advisories/crawl4ai-llm-credential-exfiltration-via-base-url-and-environment-variable-resolution
Get alerted when CVE-2026-56259 or the next vulnerability affects your stack