What’s Vulnerable › Vulnerabilities
CVE-2026-56264: Crawl4AI - Arbitrary JavaScript Execution via /execute_js Endpoint
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-30 · updated 2026-07-06
- Weakness: CWE-94
Description
Crawl4AI before 0.8.7 contains an arbitrary JavaScript execution vulnerability in the Docker API server's /execute_js endpoint, which accepts and executes arbitrary user-supplied JavaScript in the server's browser context with --disable-web-security enabled. An attacker can execute arbitrary JavaScript and, combined with the browser's relaxed security settings, perform server-side request forgery against internal services.
Affected products
- unclecode crawl4ai: before 0.8.7 — fixed in 0.8.7
How to fix
Upgrade to a fixed version: unclecode crawl4ai 0.8.7. Check the vendor advisory for mitigations.
References
- https://github.com/unclecode/crawl4ai
- https://github.com/unclecode/crawl4ai/security/advisories/GHSA-365w-hqf6-vxfg
- https://www.vulncheck.com/advisories/crawl4ai-arbitrary-javascript-execution-via-execute-js-endpoint
Get alerted when CVE-2026-56264 or the next vulnerability affects your stack