What’s Vulnerable › Vulnerabilities
CVE-2026-56273: Flowise - Path Traversal in Vector Store basePath Parameter
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-08 · updated 2026-07-09
- Weakness: CWE-22
Description
Flowise before 3.1.0 contains a path traversal vulnerability in Faiss and SimpleStore vector store implementations that accept unsanitized basePath parameters from authenticated users. Attackers with valid API tokens can write vector store data to arbitrary filesystem locations, potentially enabling code execution or data exfiltration.
Affected products
- FlowiseAI Flowise: before 3.1.0 — fixed in 3.1.0
How to fix
Upgrade to a fixed version: FlowiseAI Flowise 3.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-w6v6-49gh-mc9w
- https://www.vulncheck.com/advisories/flowise-path-traversal-in-vector-store-basepath-parameter
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-w6v6-49gh-mc9w
Get alerted when CVE-2026-56273 or the next vulnerability affects your stack