What’s Vulnerable › Vulnerabilities
CVE-2026-56278: Flowise - Session Hijacking via Weak Default Express Session Secret
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-30 · updated 2026-07-06
- Weakness: CWE-798
Description
Flowise before 3.1.0 (affected versions 3.0.13 and earlier) uses a weak hardcoded default secret ('flowise') for the express-session middleware when the EXPRESS_SESSION_SECRET environment variable is not set (packages/server/src/enterprise/middleware/passport/index.ts). Because this default secret is publicly visible in the source code, an attacker can forge valid signed session cookies to impersonate any user and bypass authentication.
Affected products
- FlowiseAI Flowise: before 3.1.0 — fixed in 3.1.0
How to fix
Upgrade to a fixed version: FlowiseAI Flowise 3.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-2qqc-p94c-hxwh
- https://www.vulncheck.com/advisories/flowise-session-hijacking-via-weak-default-express-session-secret
Get alerted when CVE-2026-56278 or the next vulnerability affects your stack