What’s Vulnerable › Vulnerabilities
CVE-2026-56317: Nuxt - Cross-Site Scripting via NoScript Component Slot Content
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-20 · updated 2026-06-24
- Weakness: CWE-79
Description
Nuxt before 4.4.7 (and the 3.x branch before 3.21.7) contains a cross-site scripting vulnerability in the NoScript component that writes slot content to innerHTML without escaping. Attackers can inject malicious scripts through untrusted data in NoScript slots, such as route.query parameters, which execute in the document context when the noscript tag is implicitly closed by script tags.
Affected products
- nuxt: before 3.21.7; from 4.0.0 before 4.4.7 — fixed in 3.21.7, 4.4.7
How to fix
Upgrade to a fixed version: nuxt 3.21.7, 4.4.7. Check the vendor advisory for mitigations.
References
- https://github.com/nuxt/nuxt/commit/4b054e9d95f8daf366cb144b52782047c511a66e
- https://github.com/nuxt/nuxt/commit/7fea9fd687f1dacbfb63db5fae5839896b017a0e
- https://github.com/nuxt/nuxt/security/advisories/GHSA-m3q2-p4fw-w38m
- https://www.vulncheck.com/advisories/nuxt-cross-site-scripting-via-noscript-component-slot-content
Get alerted when CVE-2026-56317 or the next vulnerability affects your stack