What’s Vulnerable › Vulnerabilities
CVE-2026-56340: vLLM - Denial of Service via Unvalidated Multimodal Embeddings
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-20 · updated 2026-10-23
- Weakness: CWE-20
Description
vLLM versions >= 0.10.2 and < 0.13.0 are missing sparse tensor validation in multimodal embeddings processing. Because PyTorch disables sparse tensor invariant checks by default, an attacker can submit crafted embedding requests with malformed (negative or out-of-bounds) tensor indices, when the prompt-embeds feature is enabled, to trigger crashes or resource exhaustion (denial of service), with potential for out-of-bounds/write-what-where memory corruption. This continues CVE-2025-62164, whose prior fix only disabled the feature by default rather than addressing the root cause.
Affected products
- vllm-project vllm: from 0.10.2 before 0.13.0 — fixed in 0.13.0
How to fix
Upgrade to a fixed version: vllm-project vllm 0.13.0. Check the vendor advisory for mitigations.
References
- https://github.com/vllm-project/vllm/security/advisories/GHSA-mcmc-2m55-j8jj
- https://www.vulncheck.com/advisories/vllm-denial-of-service-via-unvalidated-multimodal-embeddings
- https://access.redhat.com/security/cve/CVE-2026-56340
- https://bugzilla.redhat.com/show_bug.cgi?id=2491060
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-56340.json
Get alerted when CVE-2026-56340 or the next vulnerability affects your stack