What’s Vulnerable › Vulnerabilities

CVE-2026-56358: n8n - Stored Cross-Site Scripting in Form Trigger Node

Description

n8n before 1.123.25 (1.x) and before 2.11.2 (2.x), with the fix also included in 2.12.0, contains a stored cross-site scripting vulnerability in the Form Trigger node's CSS sanitization that allows authenticated users to inject malicious scripts. Attackers with workflow creation permissions can inject XSS payloads that execute persistently for all form visitors, enabling form hijacking and phishing attacks.

Affected products

How to fix

Upgrade to a fixed version: n8n-io n8n 1.123.25, 2.11.2; n8n-io n8n 1.123.25, 2.11.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-56358 or the next vulnerability affects your stack