What’s Vulnerable › Vulnerabilities
CVE-2026-56359: n8n - Cross-Site Scripting in Credential Management OAuth2 Authorization URL
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-08 · updated 2026-10-29
- Weakness: CWE-79
Description
n8n before 2.8.0 contains a cross-site scripting vulnerability in the credential management flow where authenticated users can inject malicious JavaScript URLs into OAuth2 credential Authorization URL fields. Attackers can craft malicious credentials and trick victims into clicking the OAuth authorization button, executing arbitrary scripts in their browser session with the victim's privileges.
Affected products
- n8n-io n8n: before 2.6.4; from 2.7.0 before 2.8.0 — fixed in 2.6.4, 2.8.0
- n8n-io n8n: from 2.7.0 before 2.8.0 — fixed in 2.8.0
How to fix
Upgrade to a fixed version: n8n-io n8n 2.6.4, 2.8.0; n8n-io n8n 2.8.0. Check the vendor advisory for mitigations.
References
- https://github.com/n8n-io/n8n/security/advisories/GHSA-364x-8g5j-x2pr
- https://www.vulncheck.com/advisories/n8n-cross-site-scripting-in-credential-management-oauth2-authorization-url
Get alerted when CVE-2026-56359 or the next vulnerability affects your stack