What’s Vulnerable › Vulnerabilities
CVE-2026-56370: ImageMagick - Out-of-bounds Access in ConnectedComponentsImage via connected-components Artifact
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-24 · updated 2026-10-29
- Weakness: CWE-125
Description
ImageMagick before 7.1.2-19 contains an out-of-bounds access vulnerability in ConnectedComponentsImage() when processing connected-components artifacts with invalid indices. Attackers can trigger access violations by specifying malformed connected-components definitions via CLI, causing denial of service or potential code execution.
Affected products
- ImageMagick: before 6.9.13-44; from 7.0.0-0 before 7.1.2-19 — fixed in 6.9.13-44, 7.1.2-19
- ImageMagick: from 7.0.0 before 7.1.2-19 — fixed in 7.1.2-19
How to fix
Upgrade to a fixed version: ImageMagick 6.9.13-44, 7.1.2-19; ImageMagick 7.1.2-19. Check the vendor advisory for mitigations.
References
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-pmpg-6pww-fg6q
- https://www.vulncheck.com/advisories/imagemagick-out-of-bounds-access-in-connectedcomponentsimage-via-connected-components-artifact
Get alerted when CVE-2026-56370 or the next vulnerability affects your stack