What’s Vulnerable › Vulnerabilities
CVE-2026-56372: ImageMagick - Heap Buffer Overflow Read via Unrecognized Magnify Method
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-11 · updated 2026-10-25
- Weakness: CWE-122
Description
ImageMagick before 7.1.2-19 contains a heap buffer overflow vulnerability in the magnify operation that allows attackers to read out of bounds memory. An unrecognized magnify:method value triggers an out of bounds read, potentially exposing sensitive information or causing denial of service.
Affected products
- ImageMagick: before 7.1.2-19 — fixed in 7.1.2-19
How to fix
Upgrade to a fixed version: ImageMagick 7.1.2-19. Check the vendor advisory for mitigations.
References
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-8vfj-q2cp-5m5j
- https://www.vulncheck.com/advisories/imagemagick-heap-buffer-overflow-read-via-unrecognized-magnify-method
Get alerted when CVE-2026-56372 or the next vulnerability affects your stack