What’s Vulnerable › Vulnerabilities
CVE-2026-56374: ImageMagick - Heap Buffer Overflow in FTXT Encoder via format Parameter
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-08 · updated 2026-10-25
- Weakness: CWE-125
Description
ImageMagick before 7.1.2-19 contains a heap buffer overflow vulnerability in the FTXT encoder due to missing boundary checks when parsing ftxt:format. Remote attackers can trigger an out of bounds read by crafting malicious FTXT image files to cause denial of service or information disclosure.
Affected products
- ImageMagick: before 7.1.2-19 — fixed in 7.1.2-19
How to fix
Upgrade to a fixed version: ImageMagick 7.1.2-19. Check the vendor advisory for mitigations.
References
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-w54j-7wpm-crhj
- https://www.vulncheck.com/advisories/imagemagick-heap-buffer-overflow-in-ftxt-encoder-via-format-parameter
Get alerted when CVE-2026-56374 or the next vulnerability affects your stack