What’s Vulnerable › Vulnerabilities
CVE-2026-56377: ImageMagick - Policy Bypass via Incorrect Path Validation
- Severity: low (CVSS 3.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-30 · updated 2026-10-29
- Weakness: CWE-22
Description
ImageMagick before 7.1.2-24 contains an incorrect policy check that allows attackers to create or truncate files disallowed by security policies. Remote attackers can bypass path policy restrictions in sandboxed conversion services to write arbitrary files outside intended boundaries.
Affected products
- ImageMagick: before 6.9.13-48; from 7.0.0-0 before 7.1.2-24 — fixed in 6.9.13-48, 7.1.2-24
- ImageMagick: from 7.0.0 before 7.1.2-24 — fixed in 7.1.2-24
How to fix
Upgrade to a fixed version: ImageMagick 6.9.13-48, 7.1.2-24; ImageMagick 7.1.2-24. Check the vendor advisory for mitigations.
References
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-gm48-c7f2-v67p
- https://www.vulncheck.com/advisories/imagemagick-policy-bypass-via-incorrect-path-validation
Get alerted when CVE-2026-56377 or the next vulnerability affects your stack