What’s Vulnerable › Vulnerabilities
CVE-2026-56378: ImageMagick - Heap Out-of-Bounds Read in PCD Decoder
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-21 · updated 2026-10-29
- Weakness: CWE-125
Description
ImageMagick before 7.1.2-15 (and 6.x before 6.9.13-40) contains a heap out-of-bounds read in the PCD coder's DecodeImage loop. A crafted PCD file can trigger a one-byte heap out-of-bounds read during image decoding, resulting in denial of service and potential disclosure of an adjacent heap byte.
Affected products
- ImageMagick: from 6.9.0-0 before 6.9.13-40; from 7.1.2-0 before 7.1.2-15 — fixed in 6.9.13-40, 7.1.2-15
- ImageMagick: from 7.0.0 before 7.1.2-15 — fixed in 7.1.2-15
How to fix
Upgrade to a fixed version: ImageMagick 6.9.13-40, 7.1.2-15; ImageMagick 7.1.2-15. Check the vendor advisory for mitigations.
References
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-wgxp-q8xq-wpp9
- https://www.vulncheck.com/advisories/imagemagick-heap-out-of-bounds-read-in-pcd-decoder
Get alerted when CVE-2026-56378 or the next vulnerability affects your stack