What’s Vulnerable › Vulnerabilities
CVE-2026-56379: ImageMagick - Command Injection via SVG Decoder
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-23 · updated 2026-10-29
- Weakness: CWE-116
Description
ImageMagick before 7.1.2-15 and 6.9.13-40 contains a command injection vulnerability in the SVG decoder that allows attackers to inject arbitrary MVG drawing commands. Attackers can craft malicious SVG files with injected Magick Vector Graphics commands that execute during rendering.
Affected products
- ImageMagick: before 6.9.13-40; from 7.1.0-0 before 7.1.2-15 — fixed in 6.9.13-40, 7.1.2-15
- ImageMagick: from 7.0.0 before 7.1.2-15 — fixed in 7.1.2-15
How to fix
Upgrade to a fixed version: ImageMagick 6.9.13-40, 7.1.2-15; ImageMagick 7.1.2-15. Check the vendor advisory for mitigations.
References
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-xpg8-7m6m-jf56
- https://www.vulncheck.com/advisories/imagemagick-command-injection-via-svg-decoder
- https://access.redhat.com/errata/RHSA-2026:32961
- https://access.redhat.com/security/cve/CVE-2026-56379
- https://bugzilla.redhat.com/show_bug.cgi?id=2491700
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-56379.json
Get alerted when CVE-2026-56379 or the next vulnerability affects your stack