What’s Vulnerable › Vulnerabilities
CVE-2026-56396: phpMyFAQ - Privilege Escalation via Missing Authorization in editUser() and updateUserRights()
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-21 · updated 2026-06-23
- Weakness: CWE-862
Description
phpMyFAQ before 4.1.4 contains missing authorization vulnerabilities in editUser() and updateUserRights() endpoints that allow authenticated administrators to escalate privileges. Non-SuperAdmin users with edit_user permission can set is_superadmin flag or grant arbitrary rights to escalate to SuperAdmin access.
Affected products
- thorsten phpMyFAQ: before 4.1.4 — fixed in 4.1.4
How to fix
Upgrade to a fixed version: thorsten phpMyFAQ 4.1.4. Check the vendor advisory for mitigations.
References
- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-985r-q3qp-299h
- https://www.vulncheck.com/advisories/phpmyfaq-privilege-escalation-via-missing-authorization-in-edituser-and-updateuserrights
- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-985r-q3qp-299h
Get alerted when CVE-2026-56396 or the next vulnerability affects your stack