What’s Vulnerable › Vulnerabilities
CVE-2026-56400: open-webui - Remote Code Execution via CORS Misconfiguration and Session Validation
- Severity: critical (CVSS 9.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-07-15 · updated 2026-07-16
- Weakness: CWE-613
Description
open-webui before 0.3.14 contains a cross-origin resource sharing misconfiguration allowing arbitrary origins with allow_origins=* and authenticated requests to the /api/v1/functions endpoint. Attackers can execute arbitrary code on the openwebui instance by crafting malicious cross-site requests from attacker-controlled websites when an admin user visits them.
Affected products
- open-webui: before 0.3.14 — fixed in 0.3.14
How to fix
Upgrade to a fixed version: open-webui 0.3.14. Check the vendor advisory for mitigations.
References
- https://github.com/open-webui/open-webui/security/advisories/GHSA-6xcp-7mpr-m7wm
- https://www.vulncheck.com/advisories/open-webui-remote-code-execution-via-cors-misconfiguration-and-session-validation
- https://github.com/open-webui/open-webui/security/advisories/GHSA-6xcp-7mpr-m7wm
Get alerted when CVE-2026-56400 or the next vulnerability affects your stack