What’s Vulnerable › Vulnerabilities
CVE-2026-56434: NGINX ngx_http_ssi_module vulnerability
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-15 · updated 2026-08-10
- Weakness: CWE-416
Description
NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_ssi_module module. This vulnerability may exist when the Server-Side Includes (SSI), proxy_pass, and proxy_buffering off directives are configured. With this configuration, an unauthenticated attacker with man-in-the-middle (MITM) ability to control responses from an upstream server may be able to cause a use-after-free in the NGINX worker process. This issue may lead to limited modification of memory or a restart of the NGINX worker process. Impact: This vulnerability may allow remote attackers to have limited control to modify memory contents or restart the NGINX worker process. There is no control plane exposure; this is a data plane issue only. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.
Affected products
- F5 NGINX Gateway Fabric: from 1.3.0 through 1.6.2; from 2.0.0 before 2.6.7 — fixed in 2.6.7
- F5 NGINX Ingress Controller: from 3.5.0 through 3.7.2; from 5.0.0 before 5.5.3; from 2026-lts-r1 before 2026-lts-r4; 4.0.0, 4.0.1 — fixed in 2026-lts-r4, 5.5.3
- F5 NGINX Plus: from 37.0.0.1 before 37.0.3.1; from r33 before r36; r36, r36-p1, r36-p2, r36-p3, r36-p4, r36-p5 (+1) — fixed in 37.0.3.1, r36
- F5 Waf: from 4.11.0 through 4.16.0; from 5.2.0 through 5.8.0; from 5.9.0 before 5.13.4 — fixed in 5.13.4
How to fix
Upgrade to a fixed version: F5 NGINX Gateway Fabric 2.6.7; F5 NGINX Ingress Controller 2026-lts-r4, 5.5.3; F5 NGINX Plus 37.0.3.1, r36; F5 Waf 5.13.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-56434 or the next vulnerability affects your stack