What’s Vulnerable › Vulnerabilities

CVE-2026-56698: Nuxt - Cross-Site Scripting via navigateTo open Option

Description

Nuxt versions 4.0.0 before 4.4.7 and 3.x before 3.21.7 fail to validate script-capable URLs in the navigateTo open option, allowing client-side script execution. Attackers can supply javascript: URLs through the open parameter to execute arbitrary scripts in the application's origin when user-controlled input is passed to navigateTo.

Affected products

How to fix

Upgrade to a fixed version: nuxt 3.21.7, 4.4.7. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-56698 or the next vulnerability affects your stack