What’s Vulnerable › Vulnerabilities
CVE-2026-56704: Adminer before 5.4.3 Cross-Site Scripting via MySQL Version String
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-25 · updated 2026-10-12
- Weakness: CWE-79
Description
Adminer before 5.4.3 inserts unsanitized database server version strings into script tags with valid CSP nonces without proper validation. Attackers controlling a rogue MySQL server can return crafted version strings that break out of the JavaScript context and execute arbitrary code, bypassing Content Security Policy protections.
Affected products
- vrana adminer: before 5.4.3 — fixed in 5.4.3
How to fix
Upgrade to a fixed version: vrana adminer 5.4.3. Check the vendor advisory for mitigations.
References
- https://github.com/vrana/adminer/security/advisories/GHSA-h6jr-7pr6-grgj
- https://www.vulncheck.com/advisories/adminer-before-cross-site-scripting-via-mysql-version-string
Get alerted when CVE-2026-56704 or the next vulnerability affects your stack